Username not working when adding to PT

Post here if you have a problem with your account.
Davsto
Farce of Habit
 
User avatar
Joined: June 29, 2015
Location: The land of tea-drinking and Queen-worshipping.
Pronoun: He

Post Post #0  (ISO)  » Thu Oct 27, 2016 9:32 am

To be specific, the user +__+. When I enter his name into the box for adding users to the private topic and click "Add User", it says "invalid username", not adding it to the PT. A fix for this would be appreciated.

Edit: apparently the user tag doesn't work either - memberlist.php?mode=viewprofile&u=28520
"dammit davsto" - everyone"I'm never in someone's sig :(" - McMenno
On UK time, currently UTC+0

+__+
Townie
 
User avatar
Joined: September 03, 2016

Post Post #1  (ISO)  » Fri Nov 04, 2016 8:52 am

Please someone find a fix for this.

In the meantime, it's the best town-tell ever.

mastina
Mafia Scum
 
User avatar
Joined: October 08, 2016
Location: Between Snohomish and Monroe, WA
Pronoun: She

Post Post #2  (ISO)  » Fri Dec 02, 2016 6:56 pm

Bumping this to let it be known:
It's not just +__+ who has the issue.

Any user with a + in their username cannot be added. (I had trouble adding the account Cane + Able to a hydra PT.)

This seems to be a rather serious problem, because, uh, yeah. In ANY game that uses private chat, you have a compromised slot because you know the account with the + cannot be mafia or at the very least, can't communicate with them.

ConnorJC
Goon
 
User avatar
Joined: November 15, 2016
Location: US East Coast

Post Post #3  (ISO)  » Fri Dec 02, 2016 9:28 pm

Wtf are we adding accounts by username? The username literally shouldn't matter at all.
I'll look into this.

borkjerfkin
Xenophile
 
User avatar
Joined: April 03, 2012
Location: Madison, WI
Pronoun: He

Post Post #4  (ISO)  » Thu Dec 15, 2016 10:03 am

I put in a fix for this which has been merged, but not sure if it has been deployed.
beefycheese

ConnorJC
Goon
 
User avatar
Joined: November 15, 2016
Location: US East Coast

Post Post #5  (ISO)  » Fri Dec 16, 2016 4:56 pm

I don't think it's been deployed yet.

Pinging @Kison (Is an @ the right way to mention someone on the forums?)

zoraster
Survivor
 
User avatar
Joined: June 10, 2008
Location: Sunnyvale, CA
Pronoun: He

Post Post #6  (ISO)  » Tue Dec 20, 2016 9:56 am

hey, not sure if someone is doing something, but usernames with spaces in them appear not to be adding.
.

borkjerfkin
Xenophile
 
User avatar
Joined: April 03, 2012
Location: Madison, WI
Pronoun: He

Post Post #7  (ISO)  » Tue Dec 20, 2016 10:57 am

My change broke this while fixing the original case -- I have a patch that fixes both.

Sorry for the inconvenience!
beefycheese

zoraster
Survivor
 
User avatar
Joined: June 10, 2008
Location: Sunnyvale, CA
Pronoun: He

Post Post #8  (ISO)  » Tue Dec 20, 2016 11:09 am

let me know when it's up so I can tell people who have had problems.
.

borkjerfkin
Xenophile
 
User avatar
Joined: April 03, 2012
Location: Madison, WI
Pronoun: He

Post Post #9  (ISO)  » Tue Dec 20, 2016 11:10 am

it's working for me again -- let me know if you still have issues!
beefycheese


[ + ]

Return to Help!