Wiki Access

Post here if you have a problem with your account.
ConnorJC
Goon
 
User avatar
Joined: November 15, 2016
Location: US East Coast

Post Post #0  (ISO)  » Sun Nov 20, 2016 9:44 am

I appear not to be able to login to the wiki. From my understanding I should be able to login with my username and password for the forum. My account clearly exists, as I get the bad password message instead of the invalid username message. Is there some sort of restriction on wiki accounts I don't know about (Like account age or usergroup membership)?

Kison
.GIFted
 
User avatar
Joined: January 22, 2007
Location: San Diego, CA

Post Post #1  (ISO)  » Sun Nov 20, 2016 5:13 pm

After experimenting a bit, it seems mediawiki does not like these characters in passwords: &"><

The following all work: []{};.,!@#$%_+/()*'=-~:=-~\|`?

Since the wiki uses phpBB to authenticate, there's a bit of a discrepancy between username and password requirements. I'd try to change your password and see if you are able to get in after that.

ConnorJC
Goon
 
User avatar
Joined: November 15, 2016
Location: US East Coast

Post Post #2  (ISO)  » Sun Nov 20, 2016 8:40 pm

OK thanks. I'm using a randomly generated password, so it contains most special characters on the keyboard. I'll change to something without those characters.

Side note: The passwords are hashed, right? So mediawiki is just outright rejecting passwords with those characters before actually hashing them?

Kison
.GIFted
 
User avatar
Joined: January 22, 2007
Location: San Diego, CA

Post Post #3  (ISO)  » Mon Nov 21, 2016 12:47 am

I'd have to dig into it but considering which characters don't work I suspect they are URL encoding or simply stripped from the input. The passwords aren't store in plaintext.

zakk
Jack of All Trades
 
Joined: September 01, 2013

Post Post #4  (ISO)  » Mon Nov 21, 2016 12:16 pm

Oh thank God. I was about to give MS a huge ass sideways glance
permanently retired

see here for more info


[ + ]

Return to Help!